DylanInfosec๐Ÿ›ก๏ธ's Avatar

DylanInfosec๐Ÿ›ก๏ธ

@attackthesoc.com

Dad โšญ Husband ๐’‰ญ Azure Security | IAM | DE&TH https://attackthesoc.com/ ๐Ÿคฌ๐ŸงŠ What stands in the way, becomes the way

354
Followers
589
Following
266
Posts
07.11.2024
Joined
Posts Following

Latest posts by DylanInfosec๐Ÿ›ก๏ธ @attackthesoc.com

Preview
Using KQL to Detect Gaps in your Conditional Access Strategy Conditional Access Policies serve as the frontline defenders of your Azure resources, but evolving business requirements can introduce unintended gaps. This article explores how to transform your high...

Have 4 articles I've been working on here and there for a while now, yet I complete the one I started yesterday... go figure. Idea popped into my head so wrote it out in one go.

attackthesoc.com/posts/detect... - Using KQL to Detect Gaps in your Conditional Access Strategy

23.03.2025 21:09 ๐Ÿ‘ 4 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
Post image

Becky Burke of Book Island (a picture book publisher in the UK founded by my fellow Tokarczuk translator Greet Pauwelijn) was "detained" by ICE at the Canadian border on 2/28. Her father asked that her story be shared in case someone can help her. He writes:

09.03.2025 17:02 ๐Ÿ‘ 4960 ๐Ÿ” 3560 ๐Ÿ’ฌ 191 ๐Ÿ“Œ 787

ForEach-Object (+ -Parallel when possible)

20.02.2025 19:11 ๐Ÿ‘ 2 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0

Grabs the list of emails form the 'email' column, and queries graph for the user Object Id and puts them in a separate file. *Note: even if you don't use this script, always preserve the original list sent to you.

19.02.2025 21:52 ๐Ÿ‘ 0 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
Preview
Azure-SecOps/Graph/Users/Get-UserObjectIds.ps1 at main ยท AttacktheSOC/Azure-SecOps Collection of different Azure/Entra focused solutions (Deployable templates, Function Apps, etc) - AttacktheSOC/Azure-SecOps

If you work with Application owners you know how fun initializing groups for new SSO apps is. Bulk group member upload makes it easy but app owners tend to only ever provide a big list of emails. Bulk requires UPN or OID so here's a script I always turn to github.com/AttacktheSOC...

19.02.2025 21:52 ๐Ÿ‘ 3 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0

On Device Code phishing: Some folks were confused about this so wanted to share here. A generated device code is not tied to a single user. If a shared mailbox or mailbox with other accounts with view rights is hit with a spearphish, investigate all accounts.

19.02.2025 17:22 ๐Ÿ‘ 2 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0

CISA is one of the most important agencies you may not have heard of, partly due to its relative youth, and partly due to the fact that when it does its jobโ€”which it has done admirablyโ€”it generally does not make headlines.

And now Trump is gutting it.

15.02.2025 13:29 ๐Ÿ‘ 14 ๐Ÿ” 6 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 1
Introducing a new phishing technique for compromising Office 365 accounts The ongoing global phishing campaings againts Microsoft 365 have used various phishing techniques. Currently attackers are utilising forged login sites and OAuth app consents. In this blog, Iโ€™ll intr...

As @ericazelic.bsky.social mentioned all the energy around Device Code abuse is long overdue.
To get more info about how itโ€™s done, these articles are relevant
2020 & 2022 respectively

@drazuread.bsky.social aadinternals.com/post/phishing/

@inversecos www.inversecos.com/2022/12/how-...

14.02.2025 23:21 ๐Ÿ‘ 14 ๐Ÿ” 3 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 1

Full disclosure: Needs a lot of work. An over-reliance on filename and cmdline. Performance ugh.
Also asked GPT to clean it up and consolidate it as it was a mess

@wietzebeukema.nl ArgFuscator really comes to mind on this one
๐Ÿค”Could look at the InitiatingProcess + the InitiatingAccount

14.02.2025 22:29 ๐Ÿ‘ 1 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0

Had this saved in the WIP folder forever
KQL for anti-forensics activities

github.com/AttacktheSOC...

So much can be added to this. Think 3rd party tools to aid anti-forensics, browser forensics... too much to name
OMG, look at this๐Ÿ˜ถupdates to come! github.com/MikeHorn-git...

14.02.2025 22:29 ๐Ÿ‘ 9 ๐Ÿ” 3 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0
Registry to PowerShell converter Convert PowerShell scripts into Windows executables.

Was asked by a colleague for some help with a Remediation Script and remembered this little number: reg2ps.azurewebsites.net from
@roger_zander
Thank you!

Bookmark it
If using it for Intune, modify the Check Script output. Replace any $false with a 1. and $true with 0

14.02.2025 22:28 ๐Ÿ‘ 1 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
Preview
Look into couple of suspicous registry activities Look into couple of suspicous registry activities

Just posted a new entry to my blog! Trying to hunt for couple of anomalies using MDE. A lot of problems arised, as usually.

#threathunting #mde #defender

threathunt.blog/registry-hun...

09.02.2025 12:45 ๐Ÿ‘ 1 ๐Ÿ” 1 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
let FileEvents = DeviceFileEvents
| where DeviceId == @"<device-id>"
| where ActionType endswith "AggregatedReport"
| summarize count() by bin(TimeGenerated, 1h)
| extend EventType = "FileEvents";
let ProocessEvents = DeviceProcessEvents
| where DeviceId == @"<device-id>"
| where ActionType endswith "AggregatedReport"
| summarize count() by bin(TimeGenerated, 1h)
| extend EventType = "ProocessEvents";
let NetworkEvents = DeviceNetworkEvents
| where DeviceId == @"<device-id>"
| where ActionType endswith "AggregatedReport"
| summarize count() by bin(TimeGenerated, 1h)
| extend EventType = "NetworkEvents";
let LogonEvents = DeviceLogonEvents
| where DeviceId == @"<device-id>"
| where ActionType endswith "AggregatedReport"
| summarize count() by bin(TimeGenerated, 1h)
| extend EventType = "LogonEvents";
union FileEvents, ProocessEvents, NetworkEvents, LogonEvents
| render timechart by EventType

let FileEvents = DeviceFileEvents | where DeviceId == @"<device-id>" | where ActionType endswith "AggregatedReport" | summarize count() by bin(TimeGenerated, 1h) | extend EventType = "FileEvents"; let ProocessEvents = DeviceProcessEvents | where DeviceId == @"<device-id>" | where ActionType endswith "AggregatedReport" | summarize count() by bin(TimeGenerated, 1h) | extend EventType = "ProocessEvents"; let NetworkEvents = DeviceNetworkEvents | where DeviceId == @"<device-id>" | where ActionType endswith "AggregatedReport" | summarize count() by bin(TimeGenerated, 1h) | extend EventType = "NetworkEvents"; let LogonEvents = DeviceLogonEvents | where DeviceId == @"<device-id>" | where ActionType endswith "AggregatedReport" | summarize count() by bin(TimeGenerated, 1h) | extend EventType = "LogonEvents"; union FileEvents, ProocessEvents, NetworkEvents, LogonEvents | render timechart by EventType

the simple query

28.01.2025 15:19 ๐Ÿ‘ 0 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
a timechart showing the trend of aggregated reporting events between Jan 23rd-28th for the 4 different supported tables. (No DeviceLogonEvents are shown)

a timechart showing the trend of aggregated reporting events between Jan 23rd-28th for the 4 different supported tables. (No DeviceLogonEvents are shown)

Looking at some of the Aggregated Reporting of the different tables for the past few days (23-28) for a single device. #XDR #Defender

28.01.2025 15:19 ๐Ÿ‘ 2 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0
Post image Post image Post image Post image
26.01.2025 20:32 ๐Ÿ‘ 0 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
Post image Post image Post image Post image
26.01.2025 20:32 ๐Ÿ‘ 0 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0
Post image Post image Post image Post image

Took a trip inside to get a break from the bleak winter weather

26.01.2025 20:32 ๐Ÿ‘ 0 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0
Post image

Defender Resource Hub Update - Winter 2025
defenderresourcehub.info

#Security #Learn #StayUptodate #Defenders #MicrosoftSecurity

26.01.2025 13:39 ๐Ÿ‘ 3 ๐Ÿ” 2 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0
Certificate of completion from Kopidion LLC on their course "Adversarial Thinking: The Art of Dangerous Ideas"

Certificate of completion from Kopidion LLC on their course "Adversarial Thinking: The Art of Dangerous Ideas"

Very cool course by the folks
at Kopidion LLC on how to look at things from the adversary's perspective.

Thank you for the training!

24.01.2025 22:39 ๐Ÿ‘ 2 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0
Preview
Introduction to Investigative Journalism: Digital Security Digital security may seem a little daunting at first, but increased security will help investigative journalists build trust with โ€” and protect โ€” current and future sources.

I wrote a very timely introduction to digital security for journalists for @gijn.org last fall. This guidance may also apply to activists, lawyers, and anyone else doing at-risk work these days. gijn.org/resource/int...

24.01.2025 04:10 ๐Ÿ‘ 62 ๐Ÿ” 37 ๐Ÿ’ฌ 2 ๐Ÿ“Œ 1

no way

24.01.2025 17:48 ๐Ÿ‘ 2 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0

Any and all feedback is welcome. Did sprint through quite a few things I was hoping to dive into but the presentation gods were not pleased with me on this day.

Here are the slides for MDE Deception Capabilities: github.com/AttacktheSOC...

KQLs: github.com/AttacktheSOC...
many more to trickle in

23.01.2025 22:50 ๐Ÿ‘ 2 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0

Well... that was an experience, I thought I prepared for everything, just not Teams failing. Dug out an old laptop.
Very big thanks to @cyb3rmik3.bsky.social for inviting me on and to anyone able to stick around and listen, thank you for your patience. I hope you were able to learn something new.

23.01.2025 22:50 ๐Ÿ‘ 6 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 1

Thank you, man! Been prepping for it

23.01.2025 13:13 ๐Ÿ‘ 0 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0

Will do. Always seems to be the issue, have all these things I intend to say and they all try getting out at the same time causing me to freeze up. ๐Ÿฅค

I do get to cheat a little as it's an online talk so that alone calmed the nerves a bit.

23.01.2025 02:23 ๐Ÿ‘ 1 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0

Thank you, Tim!

23.01.2025 02:17 ๐Ÿ‘ 1 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0

Thank you! Much appreciated and needed. I never heard of Toorcamp but it looks awesome

23.01.2025 01:52 ๐Ÿ‘ 1 ๐Ÿ” 0 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 0

Very excited to do my first my talk ever tomorrow. Me and public speaking arenโ€™t close friends. Nervous as hell lol but ready and excited

23.01.2025 00:58 ๐Ÿ‘ 7 ๐Ÿ” 0 ๐Ÿ’ฌ 4 ๐Ÿ“Œ 1
Preview
Greek Microsoft Security Community - 3rd Meetup with Dylan Tenebruso, Thu, Jan 23, 2025, 7:00 PM | Meetup ๐Ÿ‡ฌ๐Ÿ‡ท ฮฃฮฑฯ‚ ฮบฮฑฮปฮฟฯฮผฮต ฯƒฯ„ฮฟ ฯ€ฯฯŽฯ„ฮฟ meetup ฮณฮนฮฑ ฯ„ฮฟ 2025 ฮบฮฑฮน ฯ„ฮฟ ฯ„ฯฮฏฯ„ฮฟ ฮบฮฑฯ„ฮฌ ฯƒฮตฮนฯฮฌ ฯ„ฮทฯ‚ ฮ•ฮปฮปฮทฮฝฮนฮบฮฎฯ‚ Microsoft Security ฮšฮฟฮนฮฝฯŒฯ„ฮทฯ„ฮฑฯ‚ ฯ€ฮฟฯ… ฮธฮฑ ฯ€ฯฮฑฮณฮผฮฑฯ„ฮฟฯ€ฮฟฮนฮทฮธฮตฮฏ online ฮผฮต ฮธฮญฮผฮฑ "Artifice: Leveragin

๐Ÿ“ข Don't miss @attackthesoc.com tomorrow talking about deception with MDE!

The Greek Microsoft Security Community is thrilled to host its 3rd meetup tomorrow, featuring an exciting discussion with Dylan.

โ„น๏ธ More info on how to join โคต๏ธ
www.meetup.com/greek-micros...

22.01.2025 19:31 ๐Ÿ‘ 3 ๐Ÿ” 2 ๐Ÿ’ฌ 1 ๐Ÿ“Œ 1

๐Ÿค˜Happy to have you there man!

23.12.2024 00:58 ๐Ÿ‘ 1 ๐Ÿ” 0 ๐Ÿ’ฌ 0 ๐Ÿ“Œ 0